no.phhsnews.com


no.phhsnews.com / Slik ser du Hulu på Ubuntu og andre Linux-distribusjoner

Slik ser du Hulu på Ubuntu og andre Linux-distribusjoner


Hulu jobber ikke ut av boksen på moderne Linux-distribusjoner. Mens Netflix "virker bare" hvis du bruker Google Chrome, har Hulu DRM blitt gammel og klumpete. Du kan få Hulu til å jobbe på Linux, men det vil ta litt tilpasning.

Det var ikke alltid så vanskelig. Tilbake da Netflix gjorde livet vanskelig for Linux-brukere, tilbød Hulu selv en Linux desktop app. Men den stasjonære appen er nå avsluttet. Hulu er avhengig av Adobe Flash, og Adobe Flashs DRM-kode faller fra hverandre på Linux.

Du må bruke Firefox

RELATED: Bruke Firefox på Linux? Flash-spilleren er gammel og utdatert!

Her er problemet: Hulu er avhengig av den gamle Adobe Flash DRM-koden som krever et Linux-bibliotek kalt HAL. Denne gamle HAL-programvaren er imidlertid ganske utdatert og har ikke blitt installert som standard på moderne Linux-distribusjoner i mange år. Du må installere kompatibilitetspakker som gjør at denne HAL-baserte DRM kan fungere.

Du må også bruke Mozilla Firefox for å se Hulu. Den gamle HAL-baserte DRM fungerer bare i den eldre versjonen av Linux Flash-plugin-modulen Firefox. Den nyere PPAPI (Pepper API) -baserte Flash Player inkludert i Google Chrome fungerer ikke med Hulus gamle DRM-kode.

Ja, det betyr at du må se Netflix i Google Chrome og Hulu i Mozilla Firefox. Er ikke livet grand?

Trinn 1: Installer Flash for Firefox

Først må du installere Flash Player-plugin-modulen for Firefox. Hvis du ikke har installert Flash ennå, vil du se en melding som sier at Hulu trenger Flash installert når du prøver å se det.

Du kan vanligvis installere Flash fra Linux-distribusjonens programvarebeholdninger. For eksempel, på Ubuntu, åpne Ubuntu Software Center og søk etter "flash". Installer "Adobe Flash plug-in" -programvaren.

Pass på at du installerer Flash plugin-designet "for Mozilla," "for Firefox" eller "NPAPI" -versjonen av plugin-modulen. "PPAPI" eller "for Chrom" -versjonen av Flash fungerer bare med Chrome og Chrome-baserte nettlesere.

Trinn to: Installer det gamle HAL-biblioteket

Når du har Firefox og Flash-plugin-modulen for Firefox installert , kan du gå til Hulu nettsted og prøve å spille av en video. Du ser imidlertid sannsynligvis en feilmelding når du gjør det. Feilmeldingen sier "Det oppstod et problem å spille dette beskyttede innholdet. (Feilkode: 2203) ". Hulu vil be deg om å sørge for at HAL-pakken er installert, fjern flashbufferen og tilbakestill lisensfiler.

Hulu kobler deg til en Adobe-side som anbefaler at du installerer pakken med navnet "hal", men denne pakken er ikke lenger like presentere for installasjon på moderne versjoner av Ubuntu og andre moderne Linux-distribusjoner.

I stedet for at du har installert en versjon av hele HAL-pakken - fra "zombie HAL PPA" som kjent i Ubuntu-kretsene, sender vi deg til en mer lettvektsløsning.

Martin Wimpress, prosjektledelse for Ubuntu MATE, gir en "hal-flash" PPA som gir alt du trenger for å spille av DRM-beskyttet Flash-innhold uten å installere hele HAL-laget.

For å installere Denne programvaren må du legge til denne PPA-en til ditt Ubuntu-system (dette bør også fungere på Linux Mint og andre Ubuntu-avledede distribusjoner). Åpne en terminal fra bindestrek og lim inn eller skriv inn følgende kommandoer i rekkefølge, trykk Enter etter hver. Den første kommandoen legger til PPA, den andre nedlastingsinformasjonen om pakkene i den, og den tredje installerer HAL-biblioteket.

sudo add-apt-depot ppa: flexiondotorg / hal-flash
sudo apt-get update
sudo apt-get install libhal1-flash

Hvis du bruker en annen Linux-distribusjon - det vil si noe annet enn Ubuntu, Linux Mint eller noe som kommer fra Ubuntu - må du jakte på en HAL-pakke for Flash gitt for Linux-distribusjonen din. Det kan være en del av Linux-distribusjonens pakkelager, eller det kan være i et tredjepartsregister som det er for Ubuntu.

Når det er installert, besøk Hulu i Firefox, prøv å spille en video igjen, og det skal nå fungere i stedet for å vise deg et "beskyttet innhold" feilmelding.

Hvis du fortsetter å se en feilmelding, må du kanskje lukke Firefox og starte den på nytt. Hvis det ikke virker, prøv å starte datamaskinen på nytt helt før du fortsetter.


Dette har vært et problem i mange år nå. Adobe-siden sier at HAL må installeres på versjon 10.x og oppe av Ubuntu - som refererer til versjoner av Ubuntu, helt ut i 2010.

Adobe ønsker ikke lenger å utvikle Flash på Linux. Den virkelige løsningen her kommer ikke når Adobe løser sin Flash DRM. I stedet må Hulu bytte til moderne HTML5-basert videoavspilling, som Netflix bruker i Google Chrome. Inntil de gjør det, vil Linux-avspilling være litt stresset.


Slik setter du alarmer og tidtakere på Apple Watch

Slik setter du alarmer og tidtakere på Apple Watch

Din iPhone kan brukes som vekkerklokke, et stoppeklokke og en timer. Men hvis du har en Apple Watch, trenger du ikke å ta ut telefonen for å bruke noen av disse verktøyene. Klokken din har innebygde apper som utfører de samme funksjonene. RELATED: Slik bruker du alarmen, stoppeklokken og timeren i iOS 9 Alarmen, stoppeklokken og timeren på Apple Watch er uavhengig av de samme programmene på iPhone.

(how-to)

Er det noen risiko for å bruke Y-kabler med USB-enheter?

Er det noen risiko for å bruke Y-kabler med USB-enheter?

Noen ganger kan det være forvirrende når en teknisk spesifikasjon forbyder bruk av et bestemt tilbehørsprodukt, men alle synes å tenk å bruke elementet i spørsmålet er helt greit. Hvem er riktig til slutt? Dagens SuperUser Q & A-post har svaret på et bekymret lesers spørsmål. Dagens Spørsmål og Svar-sesjon kommer til oss med høflighet av SuperUser-en underavdeling av Stack Exchange, en fellesskapsdrevet gruppe av Q & A-nettsteder.

(how-to)